Broadband Packet Loss and Slow Speeds
Incident Report for Elite Limited
Resolved
This issue is now resolved, we are investigating the underlying cause and apologise for any inconvenience.
Posted Oct 12, 2017 - 10:05 BST
Monitoring
We have seen services start to recover and our traffic profile is returning back to normal.

We will continue to closely monitor the situation until the overall service has been fully restored.
Posted Oct 11, 2017 - 14:28 BST
Investigating
Some users may be experiencing slow speeds and packet loss on their Broadband connections. Engineers are investigating and we will update shortly.
Posted Oct 11, 2017 - 12:43 BST