Elite Help Centre Down
Incident Report for Elite Limited
Resolved
The outage with the third party support system has now been resolved

Elite will continue to update cases via this system until they are resolved and our new support system is up and running for new support cases

Please do email helpdesk@elite.net.uk or call 02392 797676 should you require any further assistance and thank you for your patience
Posted Jun 01, 2020 - 15:36 BST
Identified
We are aware of an issue that is currently affecting customers accessing their Help Centre functions and being able to raise support cases, the issue is being investigated by our third party supplier who is experiencing an outage.

Due to this outage, Elite will be bringing forward the release of our new support system

If you require urgent assistance during this time please email helpdesk@elite.net.uk or call us on 02392 797676
Posted Jun 01, 2020 - 11:34 BST
This incident affected: Customer Portals, Tools & Contact (Customer Portal).