Cloud Pool Storage Latency Issues
Incident Report for Elite Limited
Resolved
We are now confident in the pool stability. Services have been running correctly for a period of time now.

We will continue to monitor the pool for some time to come and will be contacting clients in the near future about our plans to migrate to our new platform.

We will mark this incident as closed, but please do not hesitate to contact the team if you have any residual issues or need assistance.

Once again we apologise for the inconvenience this issue will have caused.
Posted Sep 08, 2022 - 14:36 BST
Update
We are continuing to monitor service. They have been stable on this pool for some time now.

We will continue to monitor it and also work through any client tickets of any remaining services not functioning correctly.

Once again, if you still have any services not as they should be please do no hesitate to raise this with the team.
Posted Sep 08, 2022 - 09:41 BST
Monitoring
We are seeing a better improvement now.

We have been working through the backlog of servers. We think we are almost complete.

Can we please ask that you contact our noc team if your service is not yet up. They will be glad to assist you.

Once again we apologise for the inconvenience this has caused.
Posted Sep 08, 2022 - 00:42 BST
Update
We have been working on this issue with vendors, and have made some further changes to mitigate the latency.

This seems to be working.

We are working through the backlog of servers and we thank you for your patience.

Further updates to follow.
Posted Sep 07, 2022 - 23:47 BST
Update
Just a quick update to confirm that we are still working with vendors on a resolution.

We have concentrated on pool stabilisation, which we seem to be achieving. We are bringing up services in an orderly fashion.

We still have persistent latency from this pool.

In tandem we have been migrating services to another pool, however this will take some time.

Further updates to follow.
Posted Sep 07, 2022 - 22:04 BST
Update
As a further update on this issue. Working with vendors we have managed to increase performance slightly which has helped matters. However the latency still persists.

We are constantly working on this issue as a P1.

All updates will be listed here.

Once again we apologise for the issues this has caused our clients.
Posted Sep 07, 2022 - 17:18 BST
Update
We continue to work on this issue. We have been stabilising the pool. We will be migrating customers off this pool to another, but due to the latency issues this isn't a quick process. Please bear with us.

We can however offer some information for those affected by emails. Emails have been queued and delivery is continuing.

Further updates to follow.
Posted Sep 07, 2022 - 09:08 BST
Identified
This incident is an escalation fo the earlier Plesk Hosting issues seen. In addition to Plesk services, we have experienced, and continue to do so, severe latency issues affecting one of our Cloud Pools in London.

Our other Pools (accessing the same storage) appear unaffected. We are confident this is not a storage issue but an issue isolated to this single pool.

This will affect any customers with services run from this pool.

We are working with vendors and working through the night to look to resolve this as soon as we can.

PLEASE NOTE: This is also affecting parts of our ticketing system. Please ensure you log your tickets through our Portal rather than via email. Updates can also be viewed through the portal. Live chat is functioning correctly and will be available in working hours.

We apologise for the inconvenience this is causing a subset of clients.

Further updates to follow.
Posted Sep 07, 2022 - 00:01 BST
This incident affected: Hosting Services and Email Services.