Nationwide Broadband Outage
Incident Report for Elite Limited
Resolved
We are informed by our supplier that the issue is now resolved.

We will mark this as resolved but continue to monitor. We'd ask that any clients still experiencing any issues please contact our service desk.
Posted Apr 18, 2024 - 14:30 BST
Investigating
We have been made aware of a nationwide broadband outage affecting internet browsing by our supplier. Our network team is actively investigating the issue. We apologise for the inconvenience and will provide updates shortly."
Posted Apr 18, 2024 - 13:23 BST
This incident affected: Broadband Services (WBC ADSL/FTTC Services).